On Aug 18, 2006, at 11:28 AM, Justin Collins wrote:

> Why is it saying parse error on line 1 if "require 'open-uri'" is  
> on line 3 of your example?
> How are you running the file?

I think maybe Justin is on to something here. Could your editor be  
messing up the end-of-lines? I'm using TextMate and not having any  
problems.
--
Egotism is the anesthetic that dulls the pain of stupidity.
-Frank William Leahy, football coach (1908-1973)