I'm rather ignorant of SSL and ssh... but I'm wishing
for a "compatibility" layer of some kind so that I
could use the old telnet and ftp interfaces (which I
know) but do it securely.

In other words, something like:

   require 'ssh-compat'

   SSH::Compat.setup(*whatever) do
     # ...whatever...
   end

   # Now just use Net::FTP and Net::Telnet
   # "just as if" they were the originals

   # Blah blah blah...
   # all legacy code remains unchanged

   SSH::Compat.quit    # I don't mind some "teardown"
                       # if it's needed


Is this practical/reasonable?

Or is it Just As Easy to use the real secure ftp
and ssh stuff?


Thanks,
Hal