On 8/14/06, Hal Fulton <hal9000 / hypermetrics.com> wrote:
>
> Either (=>) or [=>] would be fine with me. I'd slightly prefer
> the latter.

Or we could use another %?{ } constructor, which are, after all, being
reserved for future expansion.

> But the big question is, what would the class be called? I dislike
> long names such as Association or AssociativeArray or even
> OrderedHash. (I suppose the last might be best of those.)

OHash or Assoc or even Dict (though the latter at least implies an O(1) lookup).

Also, it would probably include http://www.rcrchive.net/rcr/show/306
along the way :)

m.