Hi, I am new to OSX and am a beginner rails developer.

I installed ruby 1.84 and ruby gems and rails and for a while
everything worked well.

Recently I tried to update rails using the gems manager and it failed,
producing an error referring to an incorrect date (sorry, didn't save
that error).

Since then I re-installed the gems manager and it fails completely
with:

/usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:52:in
`initialize': uninitialized constant Gem::CommandManager::HelpCommand
(NameError)
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/cmd_manager.rb:46:in
`instance'
        from
/usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:25:in `run'
        from /usr/local/bin/gem:23


Is there someting I can do to fix this, or whould I reinstall (a URl
with clear instructions for removal + installation?) or should I
consider reinstalling ruby (how do I remove it?)

Thank you!

-- Andre