I am having a problem getting gems configured properly on my Mac (OS X 
10.4.7), hopefully someone here can help me out.  I installed ruby and 
ruby gems using the instructions at 
http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger. 
I am trying to use the XmlSimple gem, but Ruby can't seem to find it, or 
any other gems.  I did

$ sudo gem install xml-simple

which seemed to work fine.  but then

$ ruby -e "require 'xmlsimple'"
-e:1:in `require': no such file to load -- xmlsimple (LoadError)
        from -e:1

maybe gems is installed wrong?

some other, possibly useful info:
$ ruby -v
ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]
$ which ruby
/usr/local/bin/ruby
$ gem env
Rubygems Environment:
  - VERSION: 0.9.0 (0.9.0)
  - INSTALLATION DIRECTORY: /usr/local/lib/ruby/gems/1.8
  - GEM PATH:
     - /usr/local/lib/ruby/gems/1.8
  - REMOTE SOURCES:
     - http://gems.rubyforge.org

Thanks in advance!
-geoff


-- 
Posted via http://www.ruby-forum.com/.