On 8/10/06, Trans <transfire / gmail.com> wrote:
> W00t! Had to share this discovery:
>
>   http://dictionary.reference.com/browse/nonce
>
>   http://dictionary.reference.com/browse/nonce%20word
>
> T.
>

Should we ask Matz to rename the singleton to the "nonce"?  How about
a new keyword for referring to the singleton ...

class << self
   ...
end

becomes

nonce self do
  ...
end

how about

module Kernel
  def nonce( arg, &block )
    n = class << arg; self end
    return n.class_eval(&block) if block_given?
    n
  end
end


I do like the word, though -- etymology is fun!

TwP