In the process of learning Ruby, so this is a newbie question....

I used the one-click (windows) Ruby install to install Ruby 1.8.4 and
afterwards I installed other Ruby classes such as OCI8 and Ruport.   If
I use the one-click install to get a newer version of Ruby, will I need
to reinstall the other packages as well?

In case it matters, Ruport was installed via "gem", while OCI8 had its
own install script.