Lance Squire wrote:
> I'm planning on using RMagick to do thumbnails for a Rails project.
>
> Installed RMagick using 'gem install rmagick'
>
>
>   
<snip lots of stuff>
> Results:
> -------
> Rmagicktest.rb:1:in `require': no such file to load -- RMagick 
> (LoadError)
>         from Rmagicktest.rb:1
> -------
>
> Checked locations of Rmagick.so and libMagick.so
>
> -------
>  locate RMagick.so
> /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/ext/RMagick/RMagick.so
> /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/lib/RMagick.so
>  locate libMagick.so
> /usr/lib/libMagick.so
> /usr/lib/libMagick.so.9
> /usr/lib/libMagick.so.9.0.4
> -------
>
> No 'usr/local/lib/ to worry about...
>
> Any ideas on where to look/ how to fix?
>
> Thanks,
>
> Lance F. Squire
>   

If you are using a library installed with gems, you will need to

require 'rubygems'

first. Give that a try.

-Justin