I'm planning on using RMagick to do thumbnails for a Rails project.

Installed RMagick using 'gem install rmagick'

Here are last few lines...
--------------------------------------------------------------------------
gcc -fPIC -Wall -g   -I. -I/usr/lib/ruby/1.8/i386-linux 
-I/usr/lib/ruby/1.8/i386-linux 
-I/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/ext/RMagick 
-DRUBY_VERSION=0x184  -I/usr/include -c rmfill.c
gcc -fPIC -Wall -g   -I. -I/usr/lib/ruby/1.8/i386-linux 
-I/usr/lib/ruby/1.8/i386-linux 
-I/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/ext/RMagick 
-DRUBY_VERSION=0x184  -I/usr/include -c rminfo.c
gcc -fPIC -Wall -g   -I. -I/usr/lib/ruby/1.8/i386-linux 
-I/usr/lib/ruby/1.8/i386-linux 
-I/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/ext/RMagick 
-DRUBY_VERSION=0x184  -I/usr/include -c rmmain.c
gcc -shared -L/usr/lib -lfreetype -lz -L/usr/lib  -L"/usr/lib" -o 
RMagick.so rmilist.o rmdraw.o rmutil.o rmimage.o rmfill.o rminfo.o 
rmmain.o -lMagick -llcms -ltiff -lfreetype -ljpeg -lgs -lXext -lSM -lICE 
-lX11 -lXt -lbz2 -lz -lpthread -lm -lpthread -lruby  -ldl -lcrypt -lm 
-lc
make[1]: Leaving directory 
`/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/ext/RMagick'
setup.rb: entering post-setup phase...
post-setup.rb: setting up documentation...
/usr/bin/ruby -I /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I 
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick Adispatch.rb
/usr/bin/ruby -I /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I 
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick 
InitialCoords.rb
post-setup.rb: InitialCoords.rb example returned error code 256
/usr/bin/ruby -I /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I 
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick NewCoordSys.rb
post-setup.rb: NewCoordSys.rb example returned error code 256
/usr/bin/ruby -I /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I 
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick OrigCoordSys.rb
post-setup.rb: OrigCoordSys.rb example returned error code 256
/usr/bin/ruby -I /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I 
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick 
PreserveAspectRatio.rb
post-setup.rb: PreserveAspectRatio.rb example returned error code 256
/usr/bin/ruby -I /usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./lib -I 
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/./ext/RMagick RotateScale.rb
post-setup.rb: RotateScale.rb example returned error code 256

make install
/usr/bin/ruby setup.rb install

post-install.rb: installing documentation...
Successfully installed rmagick-1.13.0
------------------------------------------------------------------------

'post-setup.rb' error codes worry me...

Tried using it anyway as installation reported as 'successful' anyway.

Rails complained about not finding the methods.

tried testing the "require 'RMagick'" in irb.

------
LoadError: no such file to load -- RMagick
        from (irb):1:in `require'
        from (irb):1
------

tried the sample script from the 'Users Guide'
------
require 'RMagick'
include Magick

cat = ImageList.new("Cheetah.jpg")
cat.display
exit
-------

Results:
-------
Rmagicktest.rb:1:in `require': no such file to load -- RMagick 
(LoadError)
        from Rmagicktest.rb:1
-------

Checked locations of Rmagick.so and libMagick.so

-------
 locate RMagick.so
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/ext/RMagick/RMagick.so
/usr/lib/ruby/gems/1.8/gems/rmagick-1.13.0/lib/RMagick.so
 locate libMagick.so
/usr/lib/libMagick.so
/usr/lib/libMagick.so.9
/usr/lib/libMagick.so.9.0.4
-------

No 'usr/local/lib/ to worry about...

Any ideas on where to look/ how to fix?

Thanks,

Lance F. Squire

-- 
Posted via http://www.ruby-forum.com/.