------art_110959_29409023.1154513451228
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

As said in the title I am using windows 2000 and cannot get ruby-fcgi 0.8.7or
0.8.6 to install. Hopefully someone has gotten this working by now. In the
mailing list the only thing I could find was unanswered posts from 2 years
ago.

TIA

0.8.7 gives:

C:\ruby-fcgi>ruby install.rb config
---> lib
<--- lib
---> ext
---> ext/fcgi
c:/ruby/bin/ruby C:/ruby-fcgi/ext/fcgi/extconf.rb
install.rb:656:in `command': system("c:\\ruby\\bin\\ruby"
"C:/ruby-fcgi/ext/fcgi/extconf.rb") failed
 (RuntimeError)
        from install.rb:661:in `ruby'
        from install.rb:1237:in `extconf'
        from install.rb:1233:in `config_dir_ext'
        from install.rb:1498:in `traverse'
        from install.rb:1515:in `dive_into'
        from install.rb:1496:in `traverse'
        from install.rb:1500:in `traverse'
        from install.rb:1499:in `traverse'
        from install.rb:1515:in `dive_into'
        from install.rb:1496:in `traverse'
        from install.rb:1490:in `exec_task_traverse'
        from install.rb:1485:in `exec_task_traverse'
        from install.rb:1220:in `exec_config'
        from install.rb:991:in `exec_config'
        from install.rb:827:in `invoke'
        from install.rb:774:in `invoke'
        from install.rb:1544

C:\ruby-fcgi>

0.8.6 an error that I thought could be fixed by having fastcgiapp.h but no
matter where it is place the same error occurs and trying to enter an option
with the path seems to only give option not found errors.

C:\ruby-fcgi-0.8.6>ruby install.rb config
install.rb: entering config phase...
---> lib
<--- lib
---> ext
---> ext/fcgi
c:/ruby/bin/ruby C:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb
checking for fcgiapp.h... no
checking for fastcgi/fcgiapp.h... no
*** C:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

Provided configuration options:
        --with-opt-dir
        --without-opt-dir
        --with-opt-include
        --without-opt-includeopt-dir}/include
        --with-opt-lib
        --without-opt-libopt-dir}/lib
        --with-make-prog
        --srcdirruby-fcgi-0.8.6/ext/fcgi
        --curdir
        --ruby¥¿/ruby/bin/ruby
        --with-fcgi-dir
        --without-fcgi-dir
        --with-fcgi-include
        --without-fcgi-includefcgi-dir}/include
        --with-fcgi-lib
        --without-fcgi-libfcgi-dir}/lib
config failed
'system c:/ruby/bin/ruby C:/ruby-fcgi-0.8.6/ext/fcgi/extconf.rb ' failed
try 'ruby install.rb --help' for usage

C:\ruby-fcgi-0.8.6>

------art_110959_29409023.1154513451228--