That makes sense.  Thanks.

On 7/28/06, ara.t.howard / noaa.gov <ara.t.howard / noaa.gov> wrote:
> On Sat, 29 Jul 2006, Aleks Kissinger wrote:
>
> > So this makes sense, though nothing about the naming convention of these
> > methods makes this particularly clear.  However, this brings up the
> > question:  If something acts exactly like an integer method-wise, whats the
> > benefit of explicitly calling to_int?  This seems like a non duck-typey
> > thing to do.
>
> - it might be faster to actually have an int
>
> - you can fail early by filtering on one 'category' of behaviours guaranteed
>    by having an object respond_to? 'to_int', this is not unlike type or
>    interface checking
>
> -a
> --
> we can never obtain peace in the outer world until we make peace with
> ourselves.
> - h.h. the 14th dali lama
>
>