do you get the same error in irb when you type
require 'cairo'

cairo has a list and they may be able to help,

If you have trouble with cairo or rcairo, or you have some ideas for
how
it could be improved, please feel free to send a message to the cairo
mailinglist at cairo / cairographics.org , which is archived at

  http://cairographics.org/cgi-bin/mailman/listinfo/cairo

a post from
http://lists.freedesktop.org/archives/cairo/2006-April/006663.html
refers to 
Gdk::Drawable::create_cairo_context()