apparently, one of the problem was that what I needed was rb-gnome2
//sourceforge.net/project/showfiles.php?group_id=53614

I downloaded gnome2 all and gtk2 installed both. But I still got error
messages suggesting
problems with the installation, so I went into ruby-gtk2-0.15.0 and
hand installed gdkpixbuf, glib, gtk (and atk for good measure).

Now I get a new error,
/opt/local/lib/ruby/site_ruby/1.8/gtk2.rb:13:in `init': cannot open
display: (null) (RuntimeError)
        from /opt/local/lib/ruby/site_ruby/1.8/gtk2.rb:13
        from /opt/local/lib/ruby/vendor_ruby/1.8/gtkglext.rb:1
        from openglgtk.rb:2

http://www.ratiatum.com/forum/index.php?showtopic=22038&mode=linear
seem to suggest it might have to do with root privilege and opening an
X11 window
can't do it as a user or some such. Can anyone explain what I need to
do? 
the suggestions seem to work for linux and I am on tiger.