>Hey, thanks for the windows update!  Including FXRuby was a good idea.

It's a really neat package, I haven't done anything with it
yet but I am looking forward to working with it some.  

    >Also, since Ruby appears to not be compatible with the cygwin dll, which 
    >cygwin DLL is it being compiled with? 
    
*sigh*.  This is one of the 65,536 reasons why I hate Windows -- DLL hell.

Lyle Johnson tells me that he compiled the FXRuby I've packaged up against
the version of the cygwin dll that is provided with Ruby -- version 1.1.8-2.
If I remember rightly, we are using that version because Watanabe Hirofumi
(aka eban / os.rim.or.jp) had found problems using later versions of
cygwin (please jump in here and correct me if I'm wrong, guys!)

So the "official" word, such as it is, seems to be that the 1.6.4 Ruby
and the FXRuby I'm packaging would really like to run with 1.1.8-2, which
may or may not jive with the wishes of any other software you may be running :-)

Oh, and be sure to reboot n+1 times, where n is the number of times
you've tried to reboot so far :-)

Is this in anyway helpful?

/\ndy