On Jul 18, 2006, at 8:33, Ryan Raaum wrote:

3) Two days ago, I once again had a Ruby program fail because it's
running the wrong Ruby, and I eventually had to give up on this one. My
text editing program lets me run text through shell scripts as text
filters; so I wrote a Ruby script to pretty-format HTML. Except I can't
run it, because all the gems are installed into 1.8.4. The scripts
inherit their environment from the text editor, which inherits it from
the Finder, which does not use ~/.bash_login, nor /etc/profile, nor
/etc/bashrc, nor any other file which I can find on my system.

[It's using SOMETHING, because it has
PATH=/usr/bin:/bin:/usr/sbin:/sbin:/Users/dave, which isn't what you
get from "bash --noprofile"]

Configuring ~/.MacOSX/environment.plist will probably help this one.

Alas, I have no such file on my system. Nor even a ~/.MacOSX directory.

$ cd ~/.MacOSX
-bash: cd: /Users/dave/.MacOSX: No such file or directory

Today, in 10.4, the unix way works most of the time

Note that I do not run 10.4. There was insufficient value compared to 
cost to justify upgrading from 10.3, especially since reliability is 
greatly enhanced through consistency, and running 10.4 would mean 
upgrading 4 systems to OSX 10.4, and one to OSX 10.4 Server, a 
monumental expense. So I'm keeping all my systems synchronized on 10.3 
for now.

I believe that most of the time, it is best to recommend the unix way of
doing things as that knowledge will both continue to be useful on OS X
and is transferable to other unices.

Unlike most of the people on this list, I have every intention of 
avoiding "other Unixes."  A solution that is specific to OSX with 
greater reliability is significantly more valuable to me than one that 
applies to Unix in general but only works "most of the time" on OSX.

Your Mileage May Vary.