snacktime wrote:
> Using rails 1.1.4 I get this:
> 
> catalog1# mongrel_rails start -C config/mongrel.conf
> ** Loading settings from config/mongrel.conf (they override command 
> line).
> ** Starting Mongrel listening at 69.25.136.52:80
> ** Loading additional MIME types from config/mime.types
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:666:in
> `register': undefined method `resolve' for nil:Mongrel::URIClassifier
> (NoMethodError)
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:850:in
> `uri'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:1018:in
> `debug'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:1016:in
> `debug'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:108:in
> `cloaker_'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:832:in
> `listener'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:96:in
> `cloaker_'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:750:in
> `initialize'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:83:in
> `run'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel/command.rb:199:in
> `run'
>         from 
> /usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/bin/mongrel_rails:235
>         from /usr/local/bin/mongrel_rails:18


I've had the same problem on a clean debian installation.

'gem install mongrel' showed some messages make wasn't installed, 
however the installation seemed succesfull. I assumed compiling from 
source was just optional then.

However it will then fail with the above messages. So just install the 
make tools and reinstall the gem and the errors will go away.

-- 
Posted via http://www.ruby-forum.com/.