On 7/8/06, transfire / gmail.com <transfire / gmail.com> wrote:
>
> Please consider #object_send. The "object_" prefix indicates that it
> something best left alone -ie. this is defined by object/kernel and you
> override it only at your own peril! I think this is a great mnemonic
> device. I also think #class ought to become #object_class (which would
> also free us from having to use the receiver: self.class) That would
> give us:
>
>   object_id
>   object_class
>   object_send
>
> Then for the all methods that bypass access resitrictions:
>
>   instance_send
>   instance_eval
>   instance_exec
>   instance_variable_get
>   instance_variable_set
>   instance_variables
>
> That way it's consistant, intuitive, easy to use and easy to learn.
>

+1

Sean