Arun,

Recently there was an announcement here about Ruby-GNOME:
http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/199856
and it looks like it supports Gnome's accessibility interface:
http://developer.gnome.org/projects/gap/

Might be of interest. Not sure. There's a few links on that GAP page
(under "Audio") mentioning Gnopernicus (the links point to mp3's).

TPFJ [1]

---John

[1]: "Top-Posting For Jamal" ;)


On 7/6/06, Arun <arunlists / gmail.com> wrote:
> Hi, I'm new to Ruby and to Linux, but not to programming. I teach blind
> people how to program in New Delhi, [snip]
>
> Anyway, in looking for a programming environment well suited to Linux,
> I examined Ruby, and loved it. [snip]
>
> I'm running Ubunty Breezy, and have Gnopernicus installed, [snip]
>
> Ideas or thoughts related to any of the above would be highly
> appreciated.
>
> Arun