>
> If it's true that we have to apt-get install irb irb1.8 just for irb
> command,
> is there any way to fix such a non-intuitive installation procedure?


I used ubuntu recently and I recall that ruby was split into many  
more pieces than I expected libruby1.8, ruby1.8 (interpreter) IIRC so  
yeah it's a different beast from the WinXP one-click-installer

Kev
--
"Society in every state is a blessing, but government even in its  
best state is but a necessary evil; in it's worst state an  
intolerable one" - Thomas Paine