Hi --

On Mon, 12 Jun 2006, Daniel Schierbeck wrote:

> dblack / wobblini.net wrote:
>> It looks reasonable though I would recommend not calling the method
>> "class_methods".  That has the effect of freezing, in the language,
>> the status and purpose of singleton methods on module and class
>> objects.  I know that "class methods" is of course a conventional way
>> to refer to those methods, but I'd be sorry to see it introduced at
>> the language level at the expense of the generality of the current
>> design.
>
> I thought the same when I wrote it, but I couldn't come up with a better 
> name. It's actually hard to pinpoint a reasonable one...

Which might be telling us something.... :-)


David

-- 
David A. Black (dblack / wobblini.net)
Ruby Power and Light, LLC (http://www.rubypowerandlight.com)

See what the readers are saying about "Ruby for Rails"!
http://www.rubypowerandlight.com/quotes