On 6/9/06, transfire / gmail.com <transfire / gmail.com> wrote:
>
> transfire / gmail.com wrote:
> > Yukihiro Matsumoto wrote:
> > > I don't like the name #inherit.  Since it is not a inheritance.
> >
> > I knew you were going to say that ;) I actually hesitated to suggest
> > it, but I haven't thought of anything better. But I would like to point
> > out an interesting (albiet currently illegal) equivalency:
> >
> >   module Beanable
> >     def self.pod
> >       "oooooo"
> >     end
> >   end
> >
> >   class Beanbag
> >     extend (class << Beanable; self; end)
> >   end
>
> Considering the above (which by the way should also have an 'include
> Beanable'), a notation that has some similarity and is available for
> use:
>
>    class Beanbag
>      self << Beanable
>    end
>
> T.
>
>
>

You can say in a comment or a discussion: "check if Fooable is
imported* into Bar". But can you "check if Fooable is
double-lessed-than into Bar"?

Having both module and instance methods imported* is a concept. Just
like inclusion is right now. Concepts should have a name, imho.

* integrated/combined/merged/...


-- 
-Alder