kate rhodes wrote:
> The following is incredibly nitpicky I admit but I figure I may as
> well mention it.
> The line
> Timeout.timeout(timeout){ yield }
> 
> Is it just me or is that a lot of "timeout" Hurts a strangers
> understanding of the code. Why not change the name of the passed in
> timeout var to user_timeout or anything else that isn't just 'timeout'
> - kate = masukom

Heh, I suppose it might be. I could change that.

I remember, back in the 1.6.x days, when "timeout" was a top level 
method and I had a variable called "timeout" in my code.  That took a 
while to track down. :)

Regards,

Dan