Hi --

On Thu, 8 Jun 2006, ara.t.howard / noaa.gov wrote:

> On Thu, 8 Jun 2006 dblack / wobblini.net wrote:
>
>> I think it's a platform-specific solution -- that is, it only works on
>> Ara's computer :-)  I get the same results you get, on my Mac and on
>> a PC running Fedora.  I guess RHE must have patched Ruby in some way.
>
> nope - rhe uses ruby 1.6.8!  this is ruby compiled from source:
>
>  harp:~ > ruby --version
>  ruby 1.8.4 (2006-01-12) [i686-linux]
>
>  harp:~ > ruby -r yaml -e'  p YAML.load(YAML.dump( :"foo bar" ))  '
>  :"foo bar"
>
> what's yours?

   $ ruby -r yaml -ve 'p YAML.load(YAML.dump( :"foo bar" ))'
   ruby 1.8.4 (2005-12-24) [i686-linux]
   :"\"foo bar\""

Interesting.  What's the 2006-01-12 1.8.4?


David

-- 
David A. Black (dblack / wobblini.net)
* Ruby Power and Light, LLC (http://www.rubypowerandlight.com)
   > Ruby and Rails consultancy and training
* Author of "Ruby for Rails" from Manning Publications!
   > http://www.manning.com/black