------art_87204_20036619.1148679504629
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

On 5/26/06, James Britt <james_b / neurogami.com> wrote:
>
> Curt Hibbs wrote:
> > If you installed 184 on top of an existig installation, you'll have more
> > problems than just this. I suggest reinstalling into a new directory.
>
> :(
>
> What are these other problems?
>
> Life is so much simpler for the guy not assembling the installer when it
> installs over existing installations and Just Works.


I know. The only other problem that comes immediately to mind was that
openSSL stops working. I know there's something else, but its not coming
back to me at the moment.

>
> > Ryan Leavengood just added code to the installer script to check for
> this
> > condition, so starting with the next release, the installer won't let
> > you do
> > this.
>
> What is "this"?  Install to the same directory as a previous version?


Yes, it won't let you install over a previous installation.

If one installs to a new location, what happens to the gems, etc.,
> installed under the previous Ruby?


you'd have to reinstall the gems.

Curt

------art_87204_20036619.1148679504629--