On 5/24/06, Tim Hunter <rmagick / gmail.com> wrote:
> Mauricio Fernandez wrote:
> > On Wed, May 24, 2006 at 09:39:43PM +0900, Tim Hunter wrote:
> >> What compiler do you need to build binary extensions that are compatible
> >> with the one-click installer?
> > IIRC MSVC 6 or MinGW.
> Thanks, Mauricio.
>
> We tried building RMagick with MinGW and ran into problems (with Rails
> apps) that smell very much like they were caused by an incompatibility
> between MinGW and the compiler used for the 1.8.4 ruby-mswin binary.
> Through 1.8.2, RMagick built with MinGW has always worked just fine.

That's odd, because MinGW is supposed to be compatible with VC++6. It
would be useful to see further information.

> So I'm wondering what to do. If I'm right and MinGW-compiled binaries
> are incompatible with ruby-mswin 1.8.4, and MSVC6 is no longer available
> for free, what compiler should we use to create ruby-mswin-compatible
> compiled extensions?

It's worse: MSVC6 is no longer available at all. Even I, with an MSDN
subscription, can no longer get MSVC6, as I understand it.

-austin
-- 
Austin Ziegler * halostatue / gmail.com
               * Alternate: austin / halostatue.ca