Taked about this with Peter Vanbroekhoven some time ago (has it been a
year already?) We thought an underscore notation would be nice. May I
recommend a double underscore method:

  multiply_by_3 = method(:multiply).curry(__, 3)

Or course it would be nicer if one could just do:

  multiply_by_3 = multiply(__, 3)

But obviously that means changing Ruby itself a bit.