uncutstone wu wrote:
> I think the syntax would be changed as below:
>   File.open('somefile') do |f|
>     puts f.read
>   rescue
>     puts "Can't open"
>   end

Rather:

   File.open('pr0n') do |f|
     puts f.read
   rescue
     puts "can't read"
   end

since we won't rescue any exceptions raised by File.open, only those 
raised by File#read.


Daniel