I just tracked down a bug which killed any other applications from 
building ruby extensions; e.g. vim with --enable-rubyinterp

This is ruby-1.7.1 from yesterday's CVS (Aug 5).
Bug is in mkmf.rb:

This is the buggy original:
CONFIG = Config::MAKEFILE_CONFIG

Change it to:
CONFIG = Config::CONFIG

A trivial bug once you find it, but this will prevent other applications 
in finding "ruby.h" properly...


-- 
Wai-Sun "Squidster" Chia
Linux/Unix/Web Developer/RHCE
Professional Services