Did you install by source code?  
If so, do you have the header files tcl.h and tk.h on your system?

Did you see that the tcltklib was compiled (one of the last sources 
which are being compiled)?

> Do you have tcltklib.so?
> Perhaps in /users/dnguyen/lib/ruby/1.6/i586-linux?
> 
> (actual dir name under 'ruby/1.6' can vary)
> 
> 
> 
>  Thanks, did exactly that, but when I run the AntFarm.rb of Dave Thomas, I
> got the following
>   error message:
> 
>   /users/dnguyen/lib/ruby/1.6/tk.rb:7:in `require': No such file to load --
> tcltklib (LoadError)
>           from /users/dnguyen/lib/ruby/1.6/tk.rb:7
>           from antfarm.rb:2:in `require'
>           from antfarm.rb:2
> 
>   Even though /users/dnguyen/lib/ruby/1.6/tk.rb does exist.
>   What's still wrong?
> 
>   Dat
> 
> 
> ----------------------------------------------------------------------------
> --
>   Get your FREE download of MSN Explorer at http://explorer.msn.com
> 
> 


Wolfgang.
Phone 407-299-0273
Fax   407-299-4058