Hi,

At Thu, 2 Aug 2001 01:17:15 +0900,
Lyle Johnson wrote:
> Note that this release of FXRuby depends on FOX version 0.99.174, which can
> be downloaded from here:
> 
>     ftp://ftp.cfdrc.com/pub/FOX/fox-0.99.174.tar.gz
> 
> Please feel free to send me any questions or comments, and watch this space
> for future announcements!

Seems it doesn't compile on non-Win32 platforms because
FXRbGetInputHandle() in FXRuby.cpp tries to refer to an undeclared
variable:

c++ -fPIC -O -pipe -march=pentiumpro -fPIC -O0 -fno-strict-prototype -fpermissive -DSWIG_NOINCLUDE -Iinclude -I/usr/local/lib/ruby/1.6/i386-freebsd5.0 -I/usr/local/include -DHAVE_SYS_TIME_H   -I/usr/local/include/fox -c -o FXRuby.o FXRuby.cpp
FXRuby.cpp: In function `FXInputHandle FXRbGetInputHandle(long unsigned int)':
FXRuby.cpp:93: `fptr' undeclared (first use this function)
FXRuby.cpp:93: (Each undeclared identifier is reported only once
FXRuby.cpp:93: for each function it appears in.)
(snip)
*** Error code 1

-- 
                     /
                    /__  __            Akinori.org / MUSHA.org
                   / )  )  ) )  /     FreeBSD.org / Ruby-lang.org
Akinori MUSHA aka / (_ /  ( (__(  @ iDaemons.org / and.or.jp

"Freeze this moment a little bit longer, make each impression
  a little bit stronger..  Experience slips away -- Time stand still"