On Apr 24, 2006, at 10:52 AM, <scott.roberts / thomson.com>  
<scott.roberts / thomson.com> wrote:

> I get error during make of version 1.8.4. while trying to install  
> in the
> following environment:
>
> gcc main.o  libruby-static.a -ldl -lcrypt -lm   -o miniruby -g -O2
> -DRUBY_EXPORT  -brtl
>
> gcc: `-b' must come at the start of the command line
>
> make: *** [miniruby] Error 1
>
> AIX 5.2
>
> gcc 3.3.2
>
> GNU make 3.8
>
> Has anyone seen this before. I'm a pre-newbe so I'm not sure this  
> is the
> correct mail list for this topic. If not please let me know where I
> should go.
>

Hi Scott,

You just missed a discussion on this very same topic a couple of days  
go.
There are two write-ups on getting Ruby to compile on AIX, one I  
wrote and the other by Daniel Sheppard. Here is the link to the  
discussion you missed:

http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/189688

Hope this helps!
Christopher Gibbons