Jim Freeze wrote:

> 
> To get the posix features you want you need to go a little more manual:
> 
>> #!/usr/bin/env ruby
>>
>> require 'rubygems'
>> require 'commandline'
>>
>> class App < CommandLine::Application
>>   def initialize
>          use_posix

A-HA!

>>       options :help, :debug
>          option :posix, :flag, :names => "-d"
>          option :posix, :flag, :names => "-v",
>            :opt_found => lambda { puts "Version 1.0" }
>> % ruby example.rb -dv
> This should now work.
> 
> Jim

I shoulda grep'd a little harder!  Thanks Jim, I appreciate the effort
you've put into these libraries.  Very useful.

pb

-- 
Posted via http://www.ruby-forum.com/.