------art_13098_7319196.1144701044636
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Assuming you are an Oracle user, here's what I had to do to get the Oracle
driver 'working'.

Obvious steps:
1.  Install dbd
2. install Oracle DBI

unobvious step,
When I ran the test cases, I got this error:
Can't dlopen() a library containing Thread Local Storage:
/usr/lib/libpthread.1 - .../oci8lib.sl (LoadError)" -- from oci8.rb:7

Props to this guy, who had the solution:
http://www.alfonsomartone.itb.it/xvpucf.html

I had to set this variable :
 export LD_PRELOAD=/usr/local/lib/ruby/site_ruby/1.8/hppa2.0w-hpux11.11
/oci8lib.sl


And the majority of the tests then passed.



On 4/2/06, James Edward Gray II <james / grayproductions.net> wrote:
>
> On Apr 1, 2006, at 10:37 PM, Tim Nordloh wrote:
>
> > Yup, that's right.  I might try upgrading to a more recent version,
> > but that
> > isn't a major tweak to make.
>
> 1.8.4 is the current version of Ruby.
>
> James Edward Gray II
>
>

------art_13098_7319196.1144701044636--