Ruby seems to have very few dependencies. On my ruby 1.8.4 / linux
system it seems to require openssl for ruby itself and readline, zlib,
ncurses and gdbm for the standard libraries and other tools. Obviously
different platforms may have alternatives to these libraries instead.