I'm not sure about line numbers in SciTE, but you should definitely
upgrade to a more recent version of Ruby. There are significant
improvements in the standard libraries and interpreter, so I would
recommend upgrading to 1.8.4 ASAP. There's no need to stick with an old
version when it's so easy to install. If you're on Windows, there's a
one-click installer that'll do it all for you.