Todd Breiholz <talanb / gmail.com> wrote in
news:f28a7c470602070948m773c1086x26829941cd27c389 / mail.gmail.com: 

> I'm getting the following error when executing in Ruby 1.8.4 (tried it
> both on Windows and OS X). I did not see this problem in 1.8.2.
> 
<snip
> 
> And here is the error:
> 
> NoMethodError: You have a nil object when you didn't expect it!
> The error occured while evaluating nil.verify_mode
>         from e:/ruby/lib/ruby/1.8/net/http.rb:565:in `connect'
>         from e:/ruby/lib/ruby/1.8/net/http.rb:555:in `do_start'
>         from e:/ruby/lib/ruby/1.8/net/http.rb:544:in `start'
>         from e:/ruby/lib/ruby/1.8/net/http.rb:1031:in `request'
>         from e:/ruby/lib/ruby/1.8/net/http.rb:988:in `post2'
>         from
>         e:/ruby/lib/ruby/gems/1.8/gems/activesalesforce-0.2.2/lib/rforc
>         e.rb:230:in 
> `call_remote'
>         from
>         e:/ruby/lib/ruby/gems/1.8/gems/activesalesforce-

Did you find the problem?

I have had exactly the same - my script worked under 1.8.2 - upgrade to 
1.8.4 and boom!

Robert