I have not been following comp.lang.ruby much since 1.6.3, so please
forgive any redundancy of question.

Guy Decoux's patch for the Tk demos (Tk in general?) does not appear
to be in the 1.6.4 versions (both the standard nor the Pragmatic
Programmer's window install). Have I missed something in my absence?

The patch follows:



/u/jkaurin/ruby-1.6.4/ext/tk/lib> diff tk.rb.%1 tk.rb
948,951c948,951
<     alias __eval _eval
<     alias __invoke _invoke
<     private :__eval
<     private :__invoke
---
>     alias old_eval _eval
>     alias old_invoke _invoke
>     private :old_eval
>     private :old_invoke
957c957
<   _fromUTF8(__eval(_toUTF8(cmd, @encoding)), @encoding)
---
>   _fromUTF8(old_eval(_toUTF8(cmd, @encoding)), @encoding)
959c959
<   __eval(cmd)
---
>   old_eval(cmd)
966c966
<   _fromUTF8(__invoke(*cmds), @encoding)
---
>   _fromUTF8(old_invoke(*cmds), @encoding)
968c968
<   __invoke(*cmds)
---
>   old_invoke(*cmds)