On 3/14/06, Yukihiro Matsumoto <matz / ruby-lang.org> wrote:
> Hi,
>
> In message "Re: Alternate notation for eigenclass"
>     on Wed, 15 Mar 2006 11:22:22 +0900, dblack / wobblini.net writes:
>
> |Of course all of this may change if the use of classes to implement
> |per-object behavior changes.  I think that's why Matz hasn't wanted to
> |have a singleton_class method (i.e., it couples the concept to much to
> |the implementation).
>
> It was the original reason.  But I changed my mind.  The only reason
> we don't have eigenclass (or singleton_class) method is absence of the
> best name, which 100% suitable for the concept.
>

We've already got superclasses and subclasses.  I suppose the
'singleton class' name needs to express its location in that hierarchy
without suggesting any direct relationship?

At the risk of starting another naming thread, what about?:
Overclass, Underclass, Anchorclass, Embedded Class, Intrinsic Class,
Innate Class.

Or, since it's so hard to come up with a word for this, how about
Nameless Class?