Hi,

I am using ruby on Windows NT 4.0 with the cygwin installation (just
downloaded the latest cygwin from http://sources.redhat.com/cygwin). 
I downloaded the Windows binary for FXRuby and copied the fox.so to
the recommended location:

     /home/ruby/lib/ruby/1.6/i386-cygwin

(ruby root is /home/ruby)

When I try to load the fox module, I get the following error:

$ irb
irb(main):001:0> require 'fox'
LoadError: dlopen: Win32 error 127 -
/home/ruby/lib/ruby/1.6/i386-cygwin/fox.so
        from (irb):1:in `require'
        from (irb):1
irb(main):002:0>



I get this error when running a script as well as from irb.

Any idea what might be wrong?  I've tried adding the
/home/ruby/lib/ruby/1.6/i386-cygwin/fox.so to my LD_LIBRARY_PATH but
this didn't help.  I don't think this is a cywgin1.dll clash because
all the other cygwin commands are working fine and ruby seems to be
working fine in all other respects.  It seems to be able to find the
library but there is an error in loading it...

Thanks,

Robbie Gilbert
rgilbert1 / mindspring.com