On Mon, 13 Mar 2006, Joel VanderWerf wrote:

> Ara.T.Howard wrote:
>>
>> any idea if this behaviour is intended or not?
>>
>>
>>   mussel:~/eg/ruby/nrtlib/nrtlib-0.0.0 > cat a.rb
>>   #
>>   # the problem
>>   #
>>     module NRT
>>       class Subscription
>>         def process_incoming
>>           raise NotImplementedError
>>         end
>>         alias_method "run", "process_incoming"
>
> Unfortunately (?) what this^^^ does is define run to be a copy of the
> method process_incoming, rather than define run as a method that
> delegates to process_incoming.
>
> I suppose this behavior is necessary if you want to use alias_method to
> wrap an old method, regardless of what gets redefined in child classes.

doh!  yup - yer right.  i like my 'anonym' method more and more.  perhaps an
option to alias_method like

   alias_method "foo", "bar", :dup => false

or, more concise

   alias_method "foo", "bar", false

though i detest dangling bool arguments (method(true, false, true, true,
false) acckkkk!)...

either that or alias_method should be renamed copy_method ;-)

thoughts?

-a

-- 
share your knowledge.  it's a way to achieve immortality.
- h.h. the 14th dali lama