On Sun, 2006-02-26 at 10:59 +0900, Daniel Harple wrote:
> On Feb 26, 2006, at 1:32 AM, Ross Bamford wrote:
> 
> > I'm not sure about this - I'm still finding my way around some things
> > here, but I'm pretty sure we do need iconv_open(3) in libiconv.  
> > Does it
> > compile with this change?
> 
> The problem is really strange. I have libiconv-1.9 installed in
> /usr, and libiconv-1.10 installed in /opt/local. mkmf says
> iconv_open(3) isn't available in v1.10, but it is. Have you
> tested with libiconv-1.10? Was there ever a libiconv that did not
> have iconv_open()?
> 

Hmm. The website lists 1.9.1 as the latest stable release. I need to
look more into this I think, but one thing you might try is specifying
--with-iconv-lib and --with-iconv-include separately, rather than
--with-iconv-dir. 

> > If you are passing --with-xml2-<whatever> settings, you should be fine
> > to comment-out the lines that run those scripts (for both CFLAGS and
> > LDFLAGS). If that works for you I'll fix it with a default to the
> > dir_config and commit it.
> 
> I did this, and all unittests passed.

Thanks, I'll commit that fix tomorrow.

-- 
Ross Bamford - rosco / roscopeco.REMOVE.co.uk