hi there,

i just installed mongrel 0.32 with my rails app and got this,

-bash-3.00$ mongrel_rails start -p 8081
Running Mongrel server in development mode at 0.0.0.0:8081
Server ready.
ERROR(NoMethodError): undefined method `readpartial' for
#<TCPSocket:0x8e44cc4>
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:351:in
`process_client'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:331:in
`initialize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:330:in
`timeout'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:330:in
`initialize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:327:in
`initialize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:327:in
`new'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:327:in
`initialize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:327:in
`times'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel.rb:327:in
`initialize'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/bin/mongrel_rails:166:in
`new'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/bin/mongrel_rails:166:in
`start_mongrel'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/bin/mongrel_rails:181:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/lib/mongrel/command.rb:183:in
`run'
/usr/local/lib/ruby/gems/1.8/gems/mongrel-0.3.2/bin/mongrel_rails:224
/usr/local/bin/mongrel_rails:18:in `load'
/usr/local/bin/mongrel_rails:18

i do use rails partials if that has anything to do with the readpartial
(above) method, but i expect it isn't. also, script/server webrick -p
8100 works fine.

thanks for any help

BD.