Berger, Daniel <Daniel.Berger / qwest.com> wrote:

> > a[1].if?.strip.empty?
> > a[1].maybe.strip.empty?
> > a[1].and.strip.empty?
> > 
> > martin            
> 
> Looks better syntactically, but still has problems as Austin pointed
> out.

Didn't see that post :( Hopefully it'll show up on the ng side sometime
soon. The only problem I can see with it is that you get the method call
overhead even if it does nothing.

> I'd sooner accept "iff" (if and only if):
> 
> iff h["key"].dispatch -> same as: h["key"].dispatch if h["key"]
> 
> But, the idea of adding new keywords doesn't thrill me and I worry that
> it's too terse.

My strong objection to this is that it breaks the ". binds more tightly
than anything else" rule.

martin