Fixed!

I just wanted to get this into the archives, in case anybody else has
this same problem later. It turns out that PGP Desktop 9, of all
things, was causing problems. PGP Desktop 9 installs a Winsock 2
service to allow it to do on-the-fly IM and e-mail encryption without
interacting with IM and e-mail applications. Even though I had the
option to do this encryption turned off, it was still interfering with
Ruby.

The fix is to use LSP-Fix (available from
http://www.cexx.org/lspfix.htm ) to get rid of the PGPISP.dll (I
believe that's the exact name -- the DLL doesn't show up once removed)
service from your Winsock stack. Click on the "I know what I'm doing"
check-box, move said DLL to the right hand column and then click
"Finish". Ruby should start working from then on.

I'm still doing research to make sure everything came out OK. I'll
update this thread if I more information comes to light.

-Matt