Thank you both very much for the suggestions. First off I have 
$KCODE="u" in config/environment.rb (Rails). I have also tried to add it 
into the class. But the error remained.

Secondly I looked at oniguruma and I must say it looks promising. 
Unfortunately for me and my Windows (Cygwin) machine I have to compile 
it into Ruby 1.8.2-1.8.4. And I cann't get it to work. Cann't get 1.8.2 
to compile, an error which you then solve, yet another error and so one. 
Hopeless. I managed to compile 1.8.4 but when I open Ruby I get the 
error that a file is missing. I'm using the Windows one-click Ruby 
installer if anybody is wondering how on earth I managed to get Ruby 
working :). I could use 1.9.0 because this includes oniguruma. The only 
problem here is that I don't know if Rails works with it. I have 
contacted the author of oniguruma, maybe he can be conclusive as to 
whether or not oniguruma  solves my problem. When I get a response I'll 
post it here. In the mean time if anybody has any other suggestions, 
please let me hear. Thanks.

Kind regards,

Nick


-- 
Posted via http://www.ruby-forum.com/.