Thanks, I'll give this a shot. I did install all three of those (zlibc, 
zlib1g, zlib1g-dev) previously and recompiled ruby184 after to no avail. 
However, I'm not sure that I removed ALL ruby packages first, so I will 
try that.

-- 
Posted via http://www.ruby-forum.com/.