I am going to echo posts scattered throughout the Internet here and say 
I cannot get Ruby gems working due to lack of zlib. Trying to install a 
package like Rails gives the error:


/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in 
`require__':\
 no such file to load -- zlib (LoadError)

I am sure you guys have had this question many times before but your 
search engine is broken ("Application Error (Rails)") so I can't check 
the archive.

I am on Ubunutu Warty and have tried installing every package under the 
sun via apt, anything with zlib or ziplib in the name. I can't install 
ruby via apt because rails wants 1.8.4, not packaged.

-- 
Posted via http://www.ruby-forum.com/.