Zed-

	I'm still getting a timeout error even with the new version. Am I  
doing something wrong here?

root@grunt:~/mongrel-0.1.1# rake
(in /home/ez/mongrel-0.1.1)
make
make: Nothing to be done for `all'.
cp ext/http11/http11.so lib
/usr/local/bin/ruby -Ilib:test "/usr/local/lib/ruby/gems/1.8/gems/ 
rake-0.6.2/lib/rake/rake_test_loader.rb" "test/test_http11.rb" "test/ 
test_trie.rb" "test/test_ws.rb"
Loaded suite /usr/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake/ 
rake_test_loader
Started
Error result after 6 bytes of 15
.Read 18 string was 18
...Hitting server
E
Finished in 190.974664 seconds.

   1) Error:
test_simple_server(WSTest):
Errno::ETIMEDOUT: Connection timed out - connect(2)
     /usr/local/lib/ruby/1.8/net/http.rb:562:in `initialize'
     /usr/local/lib/ruby/1.8/net/http.rb:562:in `connect'
     /usr/local/lib/ruby/1.8/timeout.rb:48:in `timeout'
     /usr/local/lib/ruby/1.8/timeout.rb:76:in `timeout'
     /usr/local/lib/ruby/1.8/net/http.rb:562:in `connect'
     /usr/local/lib/ruby/1.8/net/http.rb:555:in `do_start'
     /usr/local/lib/ruby/1.8/net/http.rb:544:in `start'
     /usr/local/lib/ruby/1.8/net/http.rb:379:in `get_response'
     /usr/local/lib/ruby/1.8/net/http.rb:356:in `get'
     ./test/test_ws.rb:28:in `test_simple_server'

5 tests, 8 assertions, 0 failures, 1 errors
rake aborted!
Command failed with status (1): [/usr/local/bin/ruby -Ilib:test "/usr/ 
local...]


root@grunt:~/mongrel-0.1.1# ruby -v
ruby 1.8.4 (2005-12-24) [i686-linux]


Cheers-
-Ezra Zygmuntowicz
WebMaster
Yakima Herald-Republic Newspaper
http://yakimaherald.com
ezra / yakima-herald.com
blog: http://brainspl.at