I installed Ruby v1.6.3-1 and 1.6.4-1 (both InstallShield) and I can't
use GTK with them:

C:\devel>ruby\bin\ruby -v -e "require 'gtk'"
ruby 1.6.2 (2000-12-18) [i386-cygwin]

C:\devel>ruby-1.6.3\bin\ruby -v -e "require 'gtk'"
ruby 1.6.3 (2001-03-19) [i386-cygwin]
-e:1:in `require': dlopen: Win32 error 1114 -
/cygdrive/c/DEVEL/RUBY-1.6.3/lib/r
uby/site_ruby/1.6/i386-cygwin/gtk.so (LoadError)
        from -e:1

C:\devel>ruby-1.6.4\bin\ruby -v -e "require 'gtk'"
ruby 1.6.4 (2001-06-04) [i386-cygwin]
-e:1:in `require': dlopen: Win32 error 1114 -
/cygdrive/c/DEVEL/RUBY-1.6.4/lib/r
uby/site_ruby/1.6/i386-cygwin/gtk.so (LoadError)
        from -e:1


Error 1114 means ERROR_DLL_INIT_FAILED. Thanks Windows, it helps a lot!

Do I need to upgrade GTK? If so, where can I find the new DLLs?
I use gtk-dlls-20000215.zip.


Thanks.

Mike.
midulo.