Hi everyone,

I''m trying to figure out why rubygems won't install correctly on this
particular RHEL4 box, but it does on others.  Obviously, it's an
environment issue, but I can't track down where.  here are some
details:

Compiling ruby 1.8.4 on 6 RHEL4 machines.  5 were ok.  The one I do
the most dev on is not.  Ruby works fine, but rubygems does not:

# gem -v
/usr/local/bin/gem: line 3: require: command not found
/usr/local/bin/gem: line 4: Gem.manage_gems: command not found
/usr/local/bin/gem: line 6: syntax error near unexpected token `('
/usr/local/bin/gem: line 6: `required_version =
Gem::Version::Requirement.new(">= 1.8.0")'

gem installs with '/usr/bin/env ruby' as the default startup line, but
running this myself returns zilch:

# /usr/bin/env ruby
# /usr/bin/env ruby -v
# which gem
/usr/local/bin/gem
# which ruby
/usr/local/bin/ruby
#

Changing the shebang line in /usr/local/bin/gem to use
/usr/local/bin/ruby works as far as gem -v goes, but I'm afraid to use
it if I don't know what env vars it might use otherwise.

I have no ruby-based rpms installed anymore (I did once, but they
haven't been updated since 1.8.1, so I scrapped them).  I've rm -rf'ed
the entire ruby distribution and started from scratch, so I'm thinking
it must be environment.  Does anybody have a suggestion as to what
could cause this?  I see no obvious discrepancies between this machine
and any of the other 5.  Where should I look next?

Thank you!

Sean